Degraded Performance

Incident Report for Practice Better

Resolved

This issue is now resolved.
Posted Jan 10, 2025 - 17:10 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 10, 2025 - 13:20 EST

Investigating

We are investigating reports of degraded performance while accessing the web portal and mobile app. We will provide updates once more information is available.
Posted Jan 10, 2025 - 11:59 EST
This incident affected: Web Portal.