Square Disruption
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 20:12 EST
Investigating
Square is currently reporting issues that may affect payments through their integration. We are monitoring this and will provide an update once more information is available.
Posted Jan 31, 2024 - 16:59 EST
This incident affected: Integrations (Square).