Issues Accessing Web Portal
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Apr 26, 2022 - 10:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2022 - 10:28 EDT
Identified
We are currently investigating issues that may impact your ability to access the Web Portal. The issue has been identified and a fix is being implemented.
Posted Apr 26, 2022 - 10:19 EDT
This incident affected: Web Portal.