Email Deliverability Delays
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 13:37 EDT
Monitoring
We are currently monitoring issues with sending emails through our email service provider which may result in delays receiving emails from Practice Better. We will provide an update once more information is available.
Posted Jun 09, 2022 - 09:37 EDT
This incident affected: Email Delivery.