Natural Dispensary Disruption

Incident Report for Practice Better

Resolved

The Natural Dispensary integration is operational and the issue is now fully resolved. Thank you for your patience.
Posted Nov 24, 2025 - 16:37 EST

Identified

Natural Dispensary is currently experiencing an outage. We are monitoring and will provide an update when it is available.
Posted Nov 24, 2025 - 09:39 EST
This incident affected: Integrations (Natural Dispensary).