That Clean Life Disruption

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:04 EDT

Monitoring

Service Restored - Monitoring Performance
Posted Oct 20, 2025 - 15:35 EDT

Identified

We’re currently experiencing an outage affecting access to the That Clean Life portal and integration. The issue appears to stem from an upstream provider (AWS) outage that’s impacting our infrastructure.

Our team is actively monitoring the situation and will provide updates as soon as new information becomes available. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 11:14 EDT
This incident affected: Integrations (That Clean Life).