The Natural Dispensary Disruption

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 17:01 EST

Monitoring

As a result of maintenance being performed by Natural Dispensary, the integration is currently down.
Posted Feb 18, 2025 - 13:24 EST
This incident affected: Integrations (Natural Dispensary).