Telehealth Video Chat Connectivity Issues
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Dec 10, 2021 - 17:07 EST
Update
We are continuing to investigate this issue.
Posted Dec 10, 2021 - 17:05 EST
Update
We are continuing to investigate this issue.
Posted Dec 10, 2021 - 15:50 EST
Investigating
We are currently investigating connectivity issues with our telehealth service provider. This may impact your ability to join and conduct Practice Better telehealth sessions. We will provide more updates as they become available.
Posted Dec 10, 2021 - 15:50 EST
This incident affected: Web Portal.