Customer Support Delays

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Dec 11, 2024 - 09:28 EST

Monitoring

Responses may be delayed due to a high volume of support tickets. A member of our team will be with you as soon as possible.
Posted Nov 20, 2024 - 14:32 EST
This incident affected: Help Desk.