Community Login Issues
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 10:40 EDT
Investigating
We are currently investigating issues logging in to the Practice Better Community. Users who have previously logged in can access the Community directly by visiting https://community.practicebetter.io/home

We will provide an update once more information is available.
Posted Apr 26, 2024 - 09:51 EDT
This incident affected: Community.