Schedule delays

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Aug 07, 2024 - 16:53 EDT

Monitoring

We are monitoring an issue that may delay Practice Better scheduled notifications. We will provide an update once more information is available.
Posted Aug 07, 2024 - 10:43 EDT
This incident affected: Email Delivery.