Fax Delivery Issues
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Jul 31, 2023 - 11:55 EDT
Monitoring
Documo has reported that core fax services have been restored and previously queued faxes are now being processed. Both inbound and outbound faxing should now be operating normally.

We continue to monitor this disruption and will provide further updates as we are notified.
Posted Jul 27, 2023 - 08:44 EDT
Investigating
We are monitoring delivery issues reported by our service provider Documo. A service outage with one of their telecom carriers is impacting the ability to send and receive faxes.

Previously submitted inbound and outbound faxes will be resent as soon as the system is up and operational. If you are experiencing delivery issues please refrain from attempting to resend faxes.

An ETA for service restoration is pending and we will share an update once more information is communicated by Documo.
Posted Jul 26, 2023 - 08:57 EDT
This incident affected: Faxing.