Evexia Disruption

Incident Report for Practice Better

Resolved

The issue with our Evexia integration has been resolved. Thank you for your patience!
Posted Dec 15, 2024 - 21:57 EST

Monitoring

We are currently experiencing trouble with our Evexia integration. We are investigating and will provide an update when it is available.
Posted Dec 15, 2024 - 16:13 EST
This incident affected: Integrations (Evexia Diagnostics).