PB Payments Payout Balance Visibility Issue

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 13:25 EST

Investigating

We are currently investigating an issue affecting PB Payments where some customers may be unable to view their balance and payout information.

Payment processing is not affected — all payments continue to work normally.

We'll provide updates as we have more information.
Posted Feb 11, 2026 - 16:40 EST
This incident affected: Integrations (Stripe).