Fax Delivery Issues
Incident Report for Practice Better
Resolved
This issue is now resolved.
Posted Aug 30, 2023 - 08:41 EDT
Monitoring
We are monitoring delivery issues reported by our service provider, Documo where some outgoing faxes were held up. The issue is now resolved, and previously queued faxes are being processed.

We continue to monitor this disruption as they work through their backlog.
Posted Aug 29, 2023 - 15:27 EDT
This incident affected: Faxing.