Natural Dispensary Disruption

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 17:56 EST

Monitoring

Natural Dispensary is currently experiencing a partial outage including product searches. We are monitoring and will provide an update when it is available.
Posted Dec 03, 2025 - 11:33 EST
This incident affected: Integrations (Natural Dispensary).