Square Connectivity Issues
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted May 30, 2023 - 15:48 EDT
Investigating
Square is reporting issues that may affect Payment acceptance and Instant Transfers. We are monitoring this and will provide an update once more information is available.
Posted May 30, 2023 - 15:36 EDT
This incident affected: Integrations (Square).