Issues Accessing Web Portal
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted May 26, 2022 - 08:54 EDT
Identified
We've identified an issue accessing the Web Portal which may impact your ability to log in. Please use the following link to access your portal while we investigate this issue:

https://my.practicebetter.io

We will provide an update as soon as we have more information.
Posted May 26, 2022 - 08:06 EDT
This incident affected: Web Portal.