Customer Support Holiday Hours
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Jan 01, 2023 - 15:52 EST
Identified
Our Customer Support Team will take a few days to recharge this holiday season and you may notice a delay in responses from December 24th to January 2nd. We'll be back in full swing on January 2nd.
Posted Dec 22, 2022 - 10:13 EST
This incident affected: Help Desk.