Fax Delivery Delays
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 14:10 EDT
Investigating
We are monitoring delivery issues reported by our service provider Documo. They are investigating an issue that is leading to a slow sync of inbound faxes and outbound fax status update delays.
Posted Sep 18, 2023 - 11:43 EDT
This incident affected: Faxing.