Scheduled Event & Automation Delays

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 09:34 EDT

Investigating

The system is currently experiencing delays in the triggering of automations and scheduled tasks, including the release of program modules to clients. We apologize for the inconvenience and continue to investigate the issue.
Posted Sep 23, 2025 - 15:42 EDT
This incident affected: Web Portal.