Telehealth Video Chat Connectivity Issues
Incident Report for Practice Better
Resolved
This issue has been resolved.
Posted Oct 05, 2021 - 20:10 EDT
Monitoring
We're monitoring connectivity issues with our telehealth service provider. We will provide more updates as they become available.
Posted Oct 05, 2021 - 17:00 EDT
This incident affected: Web Portal.