Google Calendar Integration Issues
Incident Report for Practice Better
Resolved
This incident has been resolved.
Posted Jan 23, 2021 - 00:56 EST
Investigating
We are currently investigating issues with our Google Calendar integration which may affect your ability to view and sync events. We'll provide an update once we have more information available.
Posted Jan 22, 2021 - 13:28 EST
This incident affected: Integrations (Google Calendar).