Web Portal - Degraded Performance

Incident Report for Practice Better

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 13:30 EDT

Update

We are continuing to investigate this issue.
Posted Aug 24, 2026 - 13:29 EDT

Investigating

We are investigating reports of degraded performance while accessing the web portal and mobile app. We will provide updates once more information is available.
Posted Aug 24, 2026 - 13:07 EDT
This incident affected: Web Portal.